logs archiveIRC Archive / Oftc / #tor / 2010 / April / 30 / 1
dandon
arma: ah great.. -dev link
i skimmed it but they seem to relate the ports. can you mitigate this a bit by assining different ports for tcp and udp
atagar_
Tas: was it a python exception or something else?
Tas
let me try it again
atagar_: I get "Segmentation fault (core dumped)" with ./arm --help on FreeBSD, but that might well be a general problem with the python installation, usually I don't use python
that's with the tarball release
of arm
atagar_
what version of python? (try python --version)
you're right, a core dump is definitely a problem in the interpretor
Tas
Python 2.6.4 on FreeBSD 8.0
atagar_
that should be fine... weird
Tas
yep, it's probably a problem of my installation
on OpenBSD I get different python errors
with the newer versions
atagar_
still a core dump, or does this one have a stack trace?
Tas
no core dump, just script errors or so
         

atagar_
excellent, then I'd be interested in what they are ;)
Tas
let me try the tarball release and what it says when it crashes
atagar_: I hope this is only the white text (was mixed with the rest of the output). that's with Tor running as middle node and hibernating at the moment: http://pastebin.com/eFaFGYXd
that's on OpenBSD -current
and the tarball release of arm
and happens after it's running a minute or so
atagar_: it's probably not useful to test with an old version. I just used that one because it did run at all
atagar_
Tas: and the new version provides a core dump or exception on the OpenBSD system?
helpls
hello
atagar_
the issue this points out is in TorCtl, but unfortunately since that's ancient too I doubt mike will be interested :(
Tas
a bunch of error messages, but different ones :-) with which version should I test?
helpls
i have upgraded to lucid
atagar_
the new version please :)
Tas
trunk?
atagar_
sure
Tas
ok
atagar_
thanks
helpls
deb http://deb.torproject.org/torproject.org <DISTRIBUTION> main
can i put lucid in there
Tas
Tas
helpls: don#t ask me, I don't know :-)
atagar_: with trunk: http://pastebin.com/tgyAmtJs
on OpenBSD -current
nsa
or: ioerror committed revision 22255 (/check/trunk/cgi-bin): move the default service check from null to sergii
or: weasel committed revision 22256 (/check/trunk/etc): Fix a domain name
atagar_
Tas: Ah ha! If ya wouldn't mind try changing that line to: if not param in self.vals.keys() or not self.vals[param]: self.vals[param] = "Unknown"
Tas
sure
atagar_
I doubt arm will magically start working (somehow either a TorCtlClosed exception is raised indicating that tor's shut down or a socket error in order to reach that point...)
Tas
works better already :-) I get " 00:25:42 [ARM-WARN] Unable to resolve tor pid, abandoning connection listing" and a lot of " 00:25:42 [ARM-WARN] Unable to validate torrc", but that's probably because I run Tor chrooted
atagar_
yea, that would do it ;)
         

Tas
and arm stops then
atagar_
that would be the TorCtlClosed exception
Tas
hm, to test arm chrooted would require a lot of setup
but I could try on a test machine
atagar_
unfortunately I'm not sure how to track it past this point - mikeperry, you around?
Tas
with a Tor clinet
atagar_
no worries about the torrc validation issues, but the cause of the TorCtlClosed would be interesting to know
and that shouldn't have anything to do with being in a chroot jail (that's how I run it too)
Tas
ah ok
a different user thing?
I mean file permissions?
atagar_
correction, I run it in a linux chroot jail which evidently isn't as grand as the bsd version :)
Tas
I just run Tor there, not arm
atagar_
doubt it, TorCtl is allowing authentication to the control port then immediately saying it's closed - mikeperry would be a better person to help with further debugging
Tas
arm has a torrc available though, but that one doesn#t belong to the Tor process it connects to
atagar_
that's why it's complaining about the torrc not matching tor's current state
Tas
ok
atagar_: please tell me when I should test anything else
nsa
or: weasel committed revision 22257 (/check/trunk/etc): Enable SSL
Tas
atagar_: hm looks just the same with not chrooted Tor
maybe it looks for the torrc in the wrong place? it's in /etc/tor/torrc
atagar_
Tas: here's something: try starting arm with '-e C', this will only show the TorCtl events (looks like it often logs something upon death)
it says on the third page where it's looking for the torrc (though again that doesn't have to do with arm stopping)
Tas
with -e C it doesn#t show erors, but stops anyway. nearly instantly, can#t change to any other page
atagar_
Hu? You mean that the arrow keys don't change between pages after it stops?
Tas
no, I get the shell prompt back
it draws page 1 and stops
just the headlines of page 1
atagar_
that's not good... (though admittedly I've never tested the case where TorCtl doens't live through a single refresh of the screen...)
it actually dumps you to the shell without needing to quit or use ctrl+c?
Tas
yes, right after drawing the headlines
on top of the terminal
first line
should I make a screenshot?
atagar_
sure, that might help
it shouldn't be able to exit the draw loop without either quitting or crashing (though curses might be swallowing up the stack trace... uggg)
Tas
atagar_: http://i41.tinypic.com/66eoug.png
that's all, right after typing the password
atagar_
Hmmm, most of it makes sense (all tor related information is blank since the control port isn't accessable). However, still puzzled how it quits prematurely without a stack trace... :(
Tas
might have to do with the change we made?
atagar_
nope, that was a simple logic error where I wasn't taking into account that TorCtl might die on the first refresh of the screen
Tas
ah.
but why do you say the control port isn't accessable?
it should be
BarkerJr
these links are really ugly: https://trac.torproject.org/projects/tor/wiki/TheOnionRouter/BlockingIrc
did the wiki converter break them?
atagar_
Tas: TorCtl for some reason thinks it isn't accessable (again, you'd need to ping mikeperry for more help on why that's happening - most likely something to do with the chroot jails for bsd)
Tas
no, I test with a normal Tor client now
and it worked with the tarball release
atagar_
Tas: the tarball release has an old version of TorCtl which, as you pointed out, is exhibiting its own problems
BarkerJr
I have to verify my email to edit the wiki?
Tas
ah ok
so it's a TorCtrl problem
BarkerJr
not that the old wiki was any good
atagar_
yup (though it might be an unavoidable result of being in the jail - mike wrote TorCtl so he'll be able to help further)
ilf
any idea when a 'lucid' dist on http://deb.torproject.org/torproject.org/dists/ will be created?
or who to remind of that :)
atagar_
I'm not sure if helix or weasel handles that
ilf
helix: weasel: ? :)
weasel
it was released only minutes ago
the more often you ask, the longer I'll wait
ilf
he,y i just asked for the first time ever
weasel
it's nowhere near the top of my list,
and I probably will not build already released versions for lucid. maybe when there is a new tor release I'll think of adding lucid.
for now you can just use whatever was before l
it should install
(if not, please tell me)
Tas
atagar_: on my test machine there is no jail
atagar_
Tas: then I haven't a clue what's wrong :(
ilf
weasel: i had/have the karmic one installed. i just upgraded though and thought a new built would feel cleaner, but it runs fine
weasel: thanks for the cool work!
Tas
atagar_: ok, let me know when I should test more
nsa
or: [Tor Bug Tracker] #1377 was updated: #1377: lost menu bar and firefox won't start - http://trac.torproject.org/projects/tor/ticket/1377#comment:1
or: Changes (by phobos):
or: * component: Android (Orbot)-Backend / Core => Tor-Torbutton
or: [Tor Bug Tracker] #1377 was updated: #1377: lost menu bar and firefox won't start - http://trac.torproject.org/projects/tor/ticket/1377#comment:2
or: Comment(by phobos):
or: I don't understand. Can you submit a screenshot?
or: [Tor Bug Tracker] #98 was updated: #98: WSAENOBUFS: Running out of buffer space on Windows - http://trac.torproject.org/projects/tor/ticket/98#comment:56
or: Old description:
or: > Feb 06 02:47:39.469 [err] do_main_loop(): poll failed: No buffer space
or: > available [WSAENOBUFS ] [10055][...]
or: [Tor Bug Tracker] #98 was updated: #98: WSAENOBUFS: Running out of buffer space on Windows - http://trac.torproject.org/projects/tor/ticket/98#comment:57
or: Comment(by phobos):
or: Replying to [comment:56 phobos]:
or: > we're going to begin testing the latest -alpha releases on windows to[...]
or: [Tor Bug Tracker] #1377 filed by contact@&: #1377: lost menu bar and firefox won't start - http://trac.torproject.org/projects/tor/ticket/1377
or: I installe this program and plugin and now my Firefox browser won't start.
or: It displays "firefox" next to the apple icon and no other menu items
patriick
hey guise, does tor work on ubuntu lucid yet?
arma
patriick: try using the deb from the most recent actual ubuntu release
Francis_
hi I would just like to know if you use firefox browser profiles and one has collected a bunch of flash cookies, can someone read them while you are using the other one designated for tor?
arma
if you're using torbutton with its default config, then it should prevent websites from running applets, including flash applets, so they shouldn't be able to read the flash cookies.
Francis_
ok
arma
http://blog.torproject.org/bittorrent-over-tor
or https://blog.torproject.org/bittorrent-over-tor if you want to be safer
katmagic
Why isn't Tor an HTTP proxy? It seems like Privoxy/Polipo cause quite a few problems.
arma
because writing our own http proxy is hard
it wouldn't be much easier if we try to fold in an existing one
Tas
atagar_: arm runs on my FreeBSD now. recompiling all python related stuff helped :-)
probably something went wrong with some port update or so
dandon
arma: http://paste2.org/p/802231
nsa
or: atagar committed revision 22258 (/arm/trunk): Improved messaging and failover behavior if controller password defined in config is incorrect.
or: atagar committed revision 22259 (/arm/trunk/interface): fix: crashing error if TorCtl reports TorCtlClosed before the first refresh (caught by Tas)
or: [Tor Bug Tracker] #1378 filed by lunar: #1378: First window stays blank when creating a new profile - http://trac.torproject.org/projects/tor/ticket/1378
or: When Torbutton is installed as a global extension, the first window
or: displayed for a new profile stays blank.
or: From what I understood by digging the code, that first window is not
or: tagged with __tb_tor_fetched, thus trigerring the defense mechanism in[...]
dandon
anyone here?
Sebastian_
maybe
dandon
(Action) :) just a minute
Help: [...] If you do not have much bandwidth, uncheck this box. [...]
How much is much? IIRC tor didn't pick it up if there wasn't minimum of 50 KB/s
*a min.
Sebastian_
true
dandon
Sebastian_: ok.
thanks
aha.. if skype is running already tor doesn't want to use port 443 (windows)
phobos
really?
skype listens on 443?
dandon
yes.
it's optional but it's the default
you can change it
well it doesn't listen
afaik
tntcoda
Hi, is there a serious probability of http credentials being stolen at tor exit nodes? Is there any alternative protections for non-https enabled sites?
phobos
we believe the risk is the same as using free wifi (from neighbors, stores, coffee shops, etc)
tntcoda
ok thanks, makes sense
phobos
i wouldn't do it, personally
but if the site is already non-https, then anyone can see your traffic anyway
tntcoda
hmm true good point, I suppose the only benefit is it takes a slightly more trusted route via my ISP
OFFShare
a relay should have as the next hop either a relay or an exit-node. Is'nt it so? Hint..hint..
phobos
or a client
OFFShare
so if i change my dir-info i am able to enter a totally different Tor-world...
"Future-World" :)
petethepirate
I need some help getting vidalia to connect. I keep getting <Path Empty> Failed in view the network. I'm behind a wap with upnp. I have forwarded 9001 and 9030 to my ip local ip address, and have even set it as a dmz, but still can't connect! Any idea what I might be doing wrong?
It says it's connected, but check.torproject.org says it's not running, and message log says server port reachability test failed.
phobos
you may be doing it wrong
are you trying to use tor as a client or set it up as a relay?
petethepirate
phobos: I'm trying to set it up as a relay (help censored...)
katmagic
What's a C client library for SOCKS5?
phobos
did you let vidalia configure the port forwarding or did you do it yourself?
petethepirate
phobos: first I let vidalia do it, test said success. Didn't work, then I set up port forwarding on the wap, didn't work, then dmz. Each time, I reboot the router, and restarted vidalia.
OFFShare
"dante", if i remember correctly..
phobos
petethepirate: if vidalia said success for the upnp test, then it's configuring your router correctly
katmagic
Dante looks like a server implementation.
petethepirate
phobos: any idea why check.torproject.org would tell me I'm not using tor?
Is there a way I can verify that the realy is working for others?
t0rr
hello
phobos
petethepirate: check.tpo is for clients
unless you point your apps at tor, you aren't using tor
petethepirate
phobos: I'm not using it for myself. I want to set it up as a realy for others.
phobos
your isp may be blocking inbound connections
« prev 1 2 next »