logs archiveIRC Archive / Oftc / #tor / 2009 / November / 18 / 1
KingTiger
how do you fix it
mikeperry
I'm not sure.. is it actually closing entire windows when that happens?
or does it leave them open but blank
KingTiger
it closes all the windows and leaves you with 2 blank ones
mikeperry
I think it is this closing process that fu*ks up the window enumeration
because it is essentially modifying the list while enumerating it
give me like 5 min to code a test xpi for you
KingTiger
ok
mikeperry
hrmm
I appear to be hitting a different bug now
roxfiler
so tsocks has been replaced with torsocks?
mikeperry
ok I think I got it. too much python
KingTiger: https://blog.torproject.org/files/torbutton-1.2.3-pre2.xpi
KingTiger
is this alpha
         

mikeperry
no, prerelease for bugfixes on 1.2.2. there will be a few more of them before 1.2.3 comes out
i tested it on my firefox and it seems to have fixed the problem for me. but I don't use 3.5.x regularly yet
KingTiger
mikeperry: it didnt fix the bug
mikeperry
same exact bug?
KingTiger
yes
mikeperry
weird..
I reproduced it for me in 3.5 and that xpi fixes it..
does it actually do the popup still too?
and are you sure it installed properly? does your Addons window actually list Torbutton 1.2.3-pre2?
KingTiger
how did I produce the popup again
mikeperry
under Tools->Addons
KingTiger
<mikeperry> does it actually do the popup still too?
yes its the pre
it says it when i click 'about torbutton' as well
mikeperry
can you paste me yuour logs?
KingTiger
what log
s
mikeperry
if you are a linux user, you can change the about:config pref extensions.torbutton.logmethod to 0
and it will log in your command line window
if you launch firefox from the shell
and it will be easier to copy and paste the torbutton logs
which would be ideal to have at extensions.torbutton.loglevel set at 1
but will produce a lot of logs
2 might be ok, and will be less to copy
KingTiger
i have it set to 2
mikeperry
yeah, set logmethod to 0 and you can either copy from the shell window or redirect the logs to a file
are you in linux?
KingTiger
yes
mikeperry
cool
so if you could either pastebin me or email me a redirected file for the new failure, that would help
KingTiger
mikeperry: this is what happens when i try to turn off torbutton: http://pastebin.org/54679
is that what you wanted?
mikeperry
that's the old one though
KingTiger
that's the current as well
mikeperry
can you redo it with loglevel set to 1 then?
KingTiger
what variable is it again
you said the variable was 2 words
         

mikeperry
extensions.torbutton.loglevel
in about:config
KingTiger
mikeperry: http://pastebin.org/54685
mikeperry
hrm, its not even making it though the loop once...
let me whip you up a new xpi with some more logs and checks
KingTiger
ok
thanks
mikeperry
ah I think I'm reproducing it now in my ff3.5
damnit, I think this is a bug in ff3.5 itself
the removeTab method is failing
KingTiger
thats bad, because this is a good feature for people that make mistakes once in a while
mikeperry
yeah I know
I'll try to find a workaround
I think it may have something to do with browser windows that have no tabs
KingTiger
i have 2 addons mikeperry: adblock and refcontrol. do you think those could have had anything to do with it?
mikeperry
no
I've reproduced it in a clean firefox profile
the problem is that for some reason in FF3.5 some tabs do not have a parent window linked to them
even though they actually exist inside a parent browser window
I tried hacking up the link myself, but there must be other associations that need to be created because that is not enough
KingTiger
this is a work in progress?
mikeperry
yeah, I just tried doing that now as a hack
didn't work
I wonder if it maybe has something to do with the session store stuff from FF3
maybe I should try to fix that bug first.
man this is going to be a tough one I suspect. I'm going to have to review the firefox tab creation process to try to find where it is going wrong :/
KingTiger: fyi I think this bug is your issue too, but maybe not: https://bugs.torproject.org/flyspray/index.php?do=details&id=1053
you probably should just keep an eye on that, I'm not going to be able to fix this right now
I'm going to try to fix a couple other possibly related ff3.5 bugs and see if that helps
and if not, dive deeper into the ff3. source
ff3.5
KingTiger
is there a way you can let me know when you fix it
mikeperry
yeah, that bug
add yourself as a notification on there
KingTiger
no my specific bug
mikeperry
yeah, I guess we're not sure yet if they are the same
make a new bug and put it as high priority
and if it is the same, I will just dup it
KingTiger
you want me to make a new bug?
mikeperry
actually I'm already logged in, I will just do it
but you will need to add your email to the notification section
KingTiger
could you give me a link
mikeperry
https://bugs.torproject.org/flyspray/index.php?do=details&id=1152
KingTiger
mikeperry: that bug does not accurately describe the whole problem I'm having
mikeperry
can you please update it to include more then? that is the issue I've reproduced over here
just add some comments
KingTiger
mikeperry: torbutton also wont turn off if close all tabs on tor toggle is turned on
mikeperry
"The result is that
toggling breaks "
I meant that toggling is impossible
there, updated
KingTiger
ok thanks
mikeperry: do you have to register to receive notifications?
mikeperry
not sure, I think possibly yes
KingTiger
mikeperry: i don't see a way to sign up for notifications
mikeperry
notifications tab
https://bugs.torproject.org/flyspray/index.php?do=details&id=1152&area=notify#tabs
KingTiger
mikeperry: where on that page
there is nothing
keb
if you set View, Page Style, No Style you will see the link
it is called Notifications(1)
just below that it says Add user to list
you have to be logged in to see it
KingTiger
will that notify my user account or my actual email as well?
keb
probably email, try it and see
gbear14275
hello... I am having some problems installing tor and was hoping for some pointers. The problem I am having right now is it says my proxy is refusing connections. I am setup according to the official Howto (https://www.torproject.org/docs/tor-doc-unix.html.en#using) and am using their provided config file. Anyone come across this issue before or have any advice?
Sebastian__
did you remember to restart the proxy?
gbear14275
hmm... trying to access localhost:8123 to read how to restart polipo and firefox is blocking the site... Sorry don't mean to be helpless
one sec I'll figure this out
phobos
you want to set ff to use localhost:8118
polipo with the tor config is on port 8118
polipo by default is 8123
gbear14275
so I change the settings in firefox?
Sebastian__
You should try Torbutton
it does that automatically
gbear14275
I am using torbutton
Sebastian__
oh. You should not mess with the proxy settings in torbutton or firefox, then
did it tell you to do so in any of the guides?
(If so, we should fix them)
gbear14275
Sebastian__: no... am still trying to figure out how to restart the polipo proxy... :-/. I read the man page but it didn't give a restart command but did say full documentation could be accessed through the polipo web interface... but then ran into the torbutton port block of 8123... was taking that out temporarily when phobos spoke...
Sebastian__
ah
did you install polipo using a package provided by your Linux distribution?
gbear14275
so lol... how do you restart polipo... or whats the best way to get to the polipo interface is firefox blocks the port used lol
yes I used a package
Sebastian__
If yes, then you should learn how to use that linux distribution. If it is Ubuntu or Debian, you restart polipo by saying /etc/init.d/polipo restart
gbear14275
Sebastian__: working on the learning the distrobution... alot to retain ;)
hmm... restarted polipo and still getting the "The proxy server is refusing connections" message when testing
Sebastian__
ok. Is your torbutton set to port 8118
(that should be the default)
gbear14275
I have not changed the defaults but how would I check?
is there a torbutton config file or is this a firefox config thing?
sahal
also, are you sure you added it to only the http proxy section in firefox?
Sebastian__
just right click the text in the bottom right corner
I'm never to sure how to reset Torbutton's state completely
maybe mikeperry is here to offer that missing piece of advice
gbear14275
ah... ok so I see there is a checkbox for "Use Privoxy" but i'm using polipo... would that be the issue?
Sebastian__
You should clear all your firefox proxy settings, and then toggle Torbutton
no
Torbutton just hasn't been updated, what used to be privoxy's task is now done by polipo
gbear14275
ok proxy settings say to use firefox's defaults
Sebastian__
the use privoxy thing should be checked, and the option above it toggled on
gbear14275
and I just clicked the test settings button and it gave me a internal proxy error
Sebastian__
yeah, most likely something is still not working with polipo
gbear14275
yes the radio button is selected to "Use the recommended proxy settings for my version of Firefox" and the checkbox for "use privoxy" is checked
Sebastian__
ok
so when you exectue netstat -pl
can you find polipo in the list?
gbear14275
yes
Sebastian__
which port does it show?
gbear14275
localhost:8123
Sebastian__
ok
that means you're not using our recommended config file
sahal
how do i stop firefox from adding www. when a hidden service fails to resolve?
Sebastian__
how did you set it up?
gbear14275
Sebastian__
I mean what did you actually do on your system
like, which commands did you type
I wrote part of the instructions ;)
sahal: I don't know, sorry.
StrangeCharm_
just got a google captcha with the torbutton beta
gbear14275
Sebastian__: http://pastebin.com/m4e032d51
Sebastian__: I didn't manage to restart the polipo proxy until you told me to
Sebastian__
StrangeCharm_: hah, weren't we talking about remote dns lookups and socks 5 recently?
StrangeCharm_: https://bugzilla.mozilla.org/show_bug.cgi?id=134105
StrangeCharm_
Sebastian__, hence the bug report, right?
Sebastian__
gbear14275: ok. Can you please check again that /etc/polipo/config contains the line proxyPort = 8118?
StrangeCharm_
anyway, i was just popping in to report that google is winning this little arms race. i'm off to bed
Sebastian__
StrangeCharm_: yeah, thanks for the report
a bit sad
gbear14275
Sebastian__: Yes it does. Here is my config file (not sure if i've messed anything up) http://pastebin.com/d508424aa
Sebastian__
ok. please run /etc/init.d/polipo stop and pastebin the output
then run /etc/init.d/polipo start
(or put both in the same pastebin)
gbear14275
http://pastebin.com/m87a73a0
Sebastian__
ah
your installation is somehow broken
gbear14275
already running... i just stopped it :-/
Sebastian__
I wonder if the polipo pacage you installed is garbage
gbear14275
perhaps... Its the karmic package in ubuntu...
Sebastian__
ok
ps aux
look for polipo
find it, and kill it
gbear14275
k
one sec
Sebastian__
(kill -9 pid)
gbear14275
proxy 10558 0.0 0.0 6716 428 ? Ss 04:18 0:00 /usr/bin/polipo (line from ps aux if it helps)
« prev 1 2 3 next »