logs archiveIRC Archive / Freenode / #oracle / 2010 / March / 12 / 1
zambaboo
hi guys
learning rman here
im at a point where i do backups on one system and i want to restore them on another system
where do i start?
aqd
good afternoon everyone!
anyone know why "oracle.exe" terminate immediately, after I move all oracle/data files and registry to another computer? (on windows)
i used procmon to check all read files and registry entries, but nothing is missing....
hmm all right i give up
dsdel
o0
you wonder why oracle terminates if you haven't really installed it? :D
but... you can try something I've done when I had been in a disastrous disaster restore without archive logs...
install the same, _exactly_ the same oracle to the _same_ path on the other pc
lay out the partitions and drive letters exactly the same as previous
build up the database with the initial create database script
shutdown, stop service, and copy following files:
controlfiles/redologs/datafiles/archive logs/spfile/pfile/hcdatfile/pwfile
but emca for example won't be available - you will have to remove the repository of the database by yourself
the better way is to do a backup/recovery - when you go this way you go the 'save' way and you learn about backup and restore - rman should be used
alternativly you can surely make it working with exp/imp or better expdp/impdp
aqd
dsdel: i was trying to figure out what exactly the "install" did ;)
indraveni
hi all
i installed oracle-xe-universal package in my debian lilnux
for project.net application
it was working well
suddenly today i see that the app doesn't work as its no able to connect to the oracle
/etc/init.d/oracle restart
restarted oracle, using sqlplus I am able to access the SQL> prompt also
but with localhost:8080/apex, I am unable to see the oracle admin page
could someone please point me what I am missing
is there any other service that I need to start?
need some help please
hello friends
need some help for accessing localhost:8080/apex
dsdel
set oracle_sid=XE
sqlplus "/ as sysdba"
indraveni
insufficint priviliges
should I exdecute this as oracle user?
dsdel, yes i am able to login to sysdba
su oracle , then executing this command worked
please help me, still localhost:8080/apex through browser is not working
dsdel
indraveni: check if apache is started?
indraveni
no its not started
does it need apache?
does oracle need apache?
dsdel, ?
         

dsdel
indraveni: i'm inside apex - but oracle uses apache as default http server
indraveni
oh
dsdel
err sorry: i'm not inside apex :)
indraveni
but apache is running on port 80
dsdel
but you're trying to connect on port 8080
not 80 :D
indraveni
will there be logs anywhere to dipagnize this problem?
on executing , nsping ORCL;
on executing , tnsping ORCL;
I get messages, User Parameter Files: <empty>
dsdel
sorry no idea - never used apex :/
indraveni
TNS-03505: Failed to resolve name
dsdel
I think google will work better hehe
there seems to be something wrong with your startup :D
why ORCL? isn't the sid XE?
indraveni
yeah sid is XE
dsdel
where from does the orcl come? :D
indraveni
ok now it has given me output
dsdel
:)
indraveni
this is what i get when pinging XE
Used parameter files:
Used TNSNAMES adapter to resolve the alias
Attempting to contact (DESCRIPTION = (ADDRESS = (PROTOCOL = TCP)(HOST = localhost)(PORT = 1521)) (CONNECT_DATA = (SERVER = DEDICATED) (SERVICE_NAME = XE)))
OK (0 msec)
i found the problem
my ip was not bound to localhost
thankyou dsdel
usn_work
good morning
sidh
Greetings Gentlemen
I need to replace '$$$' char by CRLF (windows linefeed and carriage return) so i tried :
update table set col1 = replace(col1,'$$$',CHR(13) CHR(10)); but it gets in error
do i have to had somethinh between CHR(13) and CHR(10)
TheBonsai
string concat operator maybe
||
sidh
great !! TheBonsai <3
usn_work
girls ...
;)
TheBonsai
hehe
         

steelnwool
hello. will doing "emca -config dbcontrol db -repos create" interupt my running oracle database at all ?
dsdel
nope
it's completly separated from the database/files
the data are primarily stored inside the sysaux/some inside the system tablespace
so take care that there is enough free space/autoextend is set huge enough
steelnwool
thought so. just need to cover my ass as a oracle noob :)
thanks.
dsdel
further some folders are created but not soo much
nah better to ask bevor killing a database :D
but as always don't perform actions on a productive database inside production times :D
steelnwool
yeah, theres tonnes of free space on file system. not sure about table spaces. cause i inherited a completey non working OEM. thus this command.
dsdel
it's a golden rule heh
steelnwool
yeah it is. i flaunt with death occasionaly.
is there a way i can check if my tablespaces are on authextend, without using OEM ?
er autoextend
dsdel
enterprise manager / not emca
it's isntalled with the client administrative selection
naturaly you can get it through v$datafiles/v$tablespaces
but out of my mind, I currently don't know exaclty how hehe
steelnwool
my oem is pooched, and someone on otn told me to run "emca -config dbcontrol db -repos create"
dsdel
google helps!
steelnwool
aye it does.
dsdel
and if you already had an emca installed - perhaps you better remove it beforehand
further every ip-address/hostname change can affect the emca - have you cahnged your hostname?
steelnwool
nope
basically i got hried, and inherited a machine and haven't done anything do it.
but when i got here, OEM was comingu p with only a blank page.
dsdel
hrhr /the best jobs/
steelnwool
one sec, i'll show you the OTN thread
dsdel
oh which browser are you using?
steelnwool
yeah, well its getting fixed, so is everything "he" broke :)
firefox and chrome. doesn't really matter , login page is blank. and oem is screwed, can't find httpd_em.conf
dsdel
inside $oracle_home there should be some dirs with the hostname inside
steelnwool
http://forums.oracle.com/forums/thread.jspa?forumID=220&threadID=1042338 there, take a gander.
yup. i'll look thru those.
dsdel
if I have time to open up a browser :D
steelnwool
.... you have time to IRC. don't tell me about time :)
dsdel
only when waiting for different submoduls to compile
zambaboo
happy friday, all
Guest30608
pff
tnx zambaboo
zambaboo
you're very welcome
hetOrakel
Hi all, i am not getting anny dbms_output in my dbms_output tab in sql-developer any-one a hint on this?
monk12
anyone know if PDO_OCI (php oracle module) needs oracle server installed to compile? i thought only instantclient is needed... but i do see some script lines in the ./configure file saying $some_var/rdbms (not sure if its defiantley used though).
TheBonsai
monk12: a client is enough, but maybe not the instantclient
monk12
TheBonsai, k i think i may have found problem, it gets to "Unsuppored Oracle Version", i dont see a case statement checking for 11.x
so the configure may need to be updated. looks like some vars are custom set for each install... so gotta I figure out what to put in the ./configure
« prev next »