logs archiveIRC Archive / Freenode / #firefox / 2015 / July / 3 / 1
richard_w
i am getting sec_error_reused_issuer_and_serial. I know why this is happening and i want to override it. Deleting the cert from the store didn't work
do i have to get a whole new profile?
ff really needs to stop enforcing these strict security guidelines on EVERY user... as a system administrator this is really annoying when handling test systems
wowaname
not to mention unve3rified ssl is better than no ssl
b0at
well, technically, for a remote system it's not because authentication is required to prevent mitm
of course, if there were a way to pin a cert or say "this hash indicates it's okay", then that would qualify as authentication
wowaname
yes
b0at
but i don't know how to do that
wowaname
i wish web browsers made it easier for users to confirm fingerprints
much in the way ssh makes you do
someone should make an addon to make this user friendly
b0at
yeah, i thought ssh was annoying until firefox got strict on us
wowaname
some kind of randomart display to confirm
it wouldnt be intrusive though
it'd let you connect but it'd show the randomart somewhere
richard_w
firefox needs some kind of "I'm not your average dumbass"-mode
         

b0at
heh, developer edition firefox is actually worse because it uses cert policies that won't come into effect until later on stable
so the result is i can't use it to log in to my electricity provider because firefox blocks it entirely
wowaname
ugh
mozilla fix your sh*t
richard_w
well... seems like the CA that i deleted when resetting the testsystem is now permanently and invisibly tied with my profile...
no entry whatsover anywhere
still fails
*whatsoever
goddammit... even after deleting the whole cert store from my profile it still gives me sec_error_reused_issuer_and_serial
even grepping the whole profile gives no results...
brosnan
richard_w: you might need to remove key3.db and the removal needs to be done without Firefox running
richard_w
brosnan: i already did that... it did not work
with a test profile it works
problem is, that this is not an issue with a self signed cert, but a whole CA
i think i need to reset my profile...
that works...
canonprinter
is there any way to remove the title bar (I believe it's called that, anyway) from the top of firefox in linux?
using linux mint 17.1, if it matters
auscompgeek
canonprinter: what are you trying to do, and why?
canonprinter
auscompgeek: I'm trying to remove the title bar, because I would like it to be as minimal as possible
vuurdraak
Q: why am I not able to install new search engines with Firefox 38.0 as distributed by Canonical for Ubuntu 14.04 LTS ?, why does https://addons.mozilla.org/en-US/firefox/search/?atype=4 say to me that I don't use a Firefox browser ?
Sorry, you need a Mozilla-based browser (such as Firefox) to install a search plugin. ... yeh right
Is there anyway I can manualy add a search engine ?
Cork
vuurdraak: works fine here, so it is an ubuntu bug
(cannonical is customizing firefox and apparently breaks something)
this is quite common
vuurdraak
is there an xpi file or what ever ff is using that i can manualy alter to add the search engine as non of the engines suplied i want to use
Cork
2-6 times a release i see questions here where the problem doesn't exist in mozillas version of firefox
vuurdraak: you would have to generate an open search file
create an html file
add a header to that html file for the open search file
vuurdraak
i didn't have a problem in my previous version of ubuntu 12 32 bit LTS, i just installed version 14.04 LTS 64 bit and it doesnt want to install i dont know either
Cork
and then host that on a web server (local files doesn't work)
vuurdraak
@.@
Tux1Tux
Hello.
Cork
vuurdraak: ya, cause they broke something so amo doesn't think you are using firefox
Tux1Tux
Is there an IRC channel made specifically for Firefox support?
Cork
Tux1Tux: this is basically it
it isn't explicitly for support though
Tux1Tux
Right. It needs to be specifically for support, so that I don't feel like I am intruding. :p
         

vuurdraak
so the output i get when disabling scripts, i see an html page, i should put that on my website and then try to load that page ?
Cork
Tux1Tux: support questions is meant to go here
Tux1Tux: but it is a community channel
Tux1Tux
Okay.
Cork
vuurdraak: no
Tux1Tux
Hello, Dulcin.
Understood.
Dulcin
Hi Tux1Tux
vuurdraak
ow this is not the support channel sorry :D
Dulcin
This is not a firefox support channel?
Tux1Tux
It isn't?
vuurdraak
maybe i should try in the ubuntu channel then , as they seem to be the one breaking FF
Tux1Tux
I'm so confused.
Cork
vuurdraak: there is one thing you could try
though i find it unlikely to be the cause
Tux1Tux
Have you tried turning it off and on again? :-D
vuurdraak
lol
Cork
you could goto the help menu in firefox and try restarts with addons disabled
and see if it works there
vuurdraak
i will try
Cork
if it does, then it means you have an extension breaking it
else ya, ask ubuntu on how to file a bug about it
(in there system)
Tux1Tux
What's the problem, Vuurdraak? (Just curious.)
Cork
Tux1Tux: his cannonical browser doesn't get identified as firefox on amo
vuurdraak
it works
i just disabled all extentions
Cork
interesting
vuurdraak
and now i can install the search engine
Cork
so start digging though the extensions and find what fiddles things up
vuurdraak
ubuntu is suplying all kind of ff modifications for ff
Cork
actually...
vuurdraak
let me try
Cork
vuurdraak: do you have a user agent switcher or something like that?
vuurdraak
no
the only extention i installed my self is noscript
Cork
and it doesn't break amo as long as you enable js on the site
vuurdraak
the rest is ubuntu suplied, i will enable one by one see what is causing it
Cork
(something it does by default)
vuurdraak
no i enabled all scripts before, its not the js
Cork
heh, that is exactly what i just said :)
vuurdraak
noscript is now enabled and it still works going to next addon :)
1st ubuntu suplied addon doesnt break it
Unity Desktop Integration seems to be the extention that breaks it
« prev 1 2 3 4 next »