logs archiveIRC Archive / Freenode / #firefox / 2015 / July / 19 / 1
jrobeson
I can't find any bugs specifically involved in enabling MSE on linux by default. is it incidentally covered by one of the other bugs?
b0at
dunno. i thought it's enabled by default since a couple versions ago, though...
jrobeson
maybe it's a specific Fedora configuration issue.
I'd test the firefox official builds, but that requires gstreamer 0.10 which I don't have
I only have 1.0
b0at
i think it uses 1.0 now
jrobeson
not yet
b0at
you can check with the build config flags
jrobeson
https://bugzilla.mozilla.org/show_bug.cgi?id=947287
b0at
about:buildconfig
on v39 on arch, for example, it uses 1.0 now
jrobeson
Fedora's RPM is built against it..
can you check the PKGBUILD and see if it specifically builds against gstreamer 1.0?
         

b0at
and last time somebody asked i was completely certain they still used 0.10, but everybody else was on 1.0 also
jrobeson
because I know Fedora did specifically pass the flag
b0at
https://projects.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/firefox
but it doesn't mention gstreamer
oh, it just downloads straight from mozilla, duh
should have realized
ok, so that means mozilla's builds use 1.0
jrobeson
that's weird, because everything indicates that the mozilla test machines still don't have gstreamer 1.0
b0at
unless it's something implicit
jrobeson
on the attached builds
but I'll just download the official binaries.
b0at
well, the firefox package doesn't pull in gstreamer at all, it looks like
https://www.archlinux.org/packages/extra/x86_64/firefox/
i'm not sure
jrobeson
so what do you see at youtube.com/html5 ?
b0at
don't know how the specify optional deps
jrobeson
on a windows machine I see 5 out of 6 checked (except VP9)
b0at
well, on a new profile the bottom three are off
but all but 264 are ok on a profile where i fiddled with stuff
jrobeson
yeah.. I came in here to ask aobut the defaults.. :)
b0at
yeah, i thought that changed in 38 or 39. must have been using the developer edition
maybe it was gstreamer that changed
jrobeson
only the developer edition I just downloaded, only 2 are checked. h264 is not checked
I have a feeling that if i installed gstreamer 0.10 plugins, then I'd have 3 checked again
b0at
jrobeson
that's a generic feature bug. not one specifically for linux
b0at
there's a whitelist that doesn't apply to nightlies, sheesh
jrobeson
because otherwise 5 wouldn't be checked on windows
and only 3 on linux
it's like the OMTC bug.. there's a meta bug.. and then there was one specifically for enabling it by default on linux
b0at
yeah, and those don't always have obvious names
jrobeson
b0at, for some reason I'm forced to enable ffmpeg to get 5 out of the 6 boxes checked :(
         

b0at
you know, mozilla's documentation really sucks these days.
jrobeson
how so?
b0at
we're down to outdated roadmaps and implications on bug comments and missing tracking bugs
when if you jiggle it just right, it mostly works
auscompgeek
b0at: MSE is disabled by default on linux due to perf issues, iirc
b0at
well they block flash more often than not anyway.
it's not like they're doing the users a favor.
auscompgeek
b0at: and what? arch builds from source, mozilla builds still use 0.10
b0at
as far as most people are concerned, web video is still in 2008
auscompgeek
jrobeson: yeah, you need to enable fragmented-mp4 to have MSE + h.264 working
jrobeson: although I seem to have VP9 support as well.
jrobeson: & wait. I have media.mediasource.webm.enabled enabled as well :P
mukul
Hi. Is there a way to prevent filechooser dialog box from opening when accessed using icedTea on firefox ?
auscompgeek
mukul: that... doesn't sound like a firefox issue at all.
gaa
hi! is http://kb.mozillazine.org/ down?
wodim
gaa, yes
powerjuce
Hi all, is there a way for me to disable extensions from running in private browsing mode?
gaa
wodim, thanks for confirming
flux242
hi, if I click on donwoload button a drop up menu shows downloaded files. I see a pdf and click on it. Instead of the system pdf reader firefox opens pdf file with a mousepad! Where do I change this?
google says tools menu - options - attachments panel - incoming tab. But I do not have options in the tools menu
enormous amount of answers, very good channel. Will recommend it to other, huh
mefistofeles
lol
« prev next »