logs archiveIRC Archive / Freenode / #firefox / 2010 / January / 23 / 1
cjohnston
Is it possible to add all the bookmarks in the bookmarks toolbar to a folder on the bookmark toolbar?
antlong
organize bookmarks
tech9iner
g'day fellow firefox'ianites.. running Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.6) Gecko/20091201 SUSE/3.5.6-1.1.1 Firefox/3.5.6 here.. for last 2 weeks now ffx has been seemingly fine and working as expected with strange exception.. i cannot open more than one session / pane?.. file - open new window generates cursor activity in me distro here.. but fails to open 2nd+ windows or sessions?.. any clues appreciated lads.. tx
antlong
hmn
run it in debug
tech9iner
(Action) googles debug..
tx antlong for feedback lad..,
antlong
np, itll help to diagnose
sixtila
its exciting that FF 3.7 is released
does it support noscript, firebug, webdeveloper, adblock...?
xangua
¿¿
sixtila
3.6
         

xangua
the latest stable is fx 3.6
sixtila
is there a documentation if the addons will still work?
xangua
sixtila: check in Addons Mozilla web
zjblabs
sixtila: we were just saying in the other #firefox that it is not likely that there will ever be a 3.7
sixtila
why not
is it going to be stopped?
zjblabs
no
sixtila
then what do you mean
zjblabs
there will be no "3.7" release
sixtila
i dont get you, sorry
zjblabs
the current "3.7a1" will be backported to 3.6 minor releases (non-ui changes)
sixtila
ok
zjblabs
with the exception of the multi-core whatnot which will also be 4.x
antlong
zjblabs: did yous fix libsqllite3 yet
zjblabs
antlong: eh?
antlong
libsqllite3.dylib
zjblabs
you must be mistaken, I had no idea I was supposed to be doing that
antlong
no
i mean you collectively
zjblabs
I'm no mozilla developer either :D
antlong
ahh
well they fu*ked up
and included a lib that exists on mac
then you tried to run firefox-bin there was a conflict and it fu*ked all of us over
for like 3 weeks noone could figure out a way around it
kbrosnan
zjblabs: that is missinformation
http://beltzner.ca/mike/2010/01/15/of-rumours-and-broken-telephones/
         

kronix
Firefox personas are a joke.
zjblabs
kronix: agreed 100%
kronix
Whoever thought it'd be a good idea to launch a gallery containing 35,000 horrendously ugly skins needs to be shot in the face.
It just makes no goddamn sense.
4.0 is supposed to streamline everything to follow the Windows Vista/7 UI guidelines and imitate Chrome somewhat...
zjblabs
kbrosnan: how?
kronix
So, in the interim, why enable users to fuglify their browsers?
kbrosnan
zjblabs: there are still plans for a 3.7 release
kronix
Personas remind me of this toolbar for IE which let you skin the top.
HotCar or something.
It was terrible in 1995, and it's terrible now.
zjblabs
kbrosnan: firstly what's the date on that? (the 15th this month: outdated) secondly: where does it say that? thirdly: a dev just told me that was the most likely scenario.
kbrosnan
zjblabs: what dev
zjblabs
kbrosnan: you haven't answer my questions yet
kbrosnan
the plans are for a release in 4-5 months
zjblabs
your article doesn't even confirm my alleged "mis-information"
kbrosnan: my point was that it will be a 3.6.x
antlong
who really cares
zjblabs
and finally, the version number doesn't matter
antlong: indeed :D
kbrosnan
3.6 shipped yesterday
zjblabs
kbrosnan: and did I ever say "3.6 isn't out yet"
kbrosnan
you said there will be no 3.7 release
zjblabs
kbrosnan: no, I said that it wasn't called "3.7"
as far as I'm concerned, this argument is over
kbrosnan
what do you mean by that? the trunk is currently v3.7a1pre
zjblabs
kbrosnan: what does the word "release" mean to you?
kbrosnan
what happend yesterday
the only plan currently is to backport the out of process plugins work to the 3.6 branch before the release of 3.7
nixbox
hi all
is there an add on for firefox which allows modification of the OS in user agent string?
mzz
there really isn't some crazy huge change in how releases work from an end user point of view.
oh wait, this #firefox doesn't have firebot
nixbox: search addons.mozilla.org for "user agent switcher"
kbrosnan
nixbox: user agent switcher addon
mzz
it lets you customize the entire user agent, including the os bit :)
nixbox
great
thanks kbrosnan and mzz
kbrosnan
though if you have 3.6 you'll need the compatablity checker addon
https://addons.mozilla.org/en-US/firefox/addon/15003
tech9iner
mk.. re my ffx refusal to run 2nd pane/sessions?.. seems corrupted extension at fault fyi lads..
tx an c4n-
Sensiva
Where can I report security problems in Firefox?
zjblabs
Sensiva: how about the bugzilla?
kbrosnan
Sensiva: can you explain a little?
zjblabs
Sensiva: kbrosnan also seems like a good guy; telling him might get something done (if it's legitimate, of course :D)
Sensiva
:D
kbrosnan
but yes assuming you have something like a DOS or remote execution, bugzilla.mozilla.org and mark the bug as secuirty sensitive
Sensiva
I was in another channel, a user posted a link, and I was naive enough to click it, the page loaded, and the firefox window started to move so fast around the desktop, and I noticed it loaded a java plugin which connected to freenode and started spamming as well
and I got klined for that
I am using Ubuntu 9.10 firefox 3.5.7, and I tested it in Windows vbox firefox 3.6 and the same thing happened
rjohnson19
That may not be considered a security exploit, just a malicious java applet and some javascript to make it difficult to stop.
NoScript would stop those kinds of things.
zjblabs
Sensiva: I too would agree that ff's javascript is a bit too liberal for my tastes (but then again, how could you stop a script like that? sounds completely legal, like rjohnson19 says)
Sensiva
I didn't say its an exploit
zjblabs
and I was about to say that ^
I find noscript to be too conservative though :D
rjohnson19
There is an option to disallow JS to move windows.
NightMonkey
Howdy. Is there a way to disable the in-browser multimedia support in FF 3.6?
kbrosnan
Sensiva: it is a bit of a hard edge case, there are legitimate reasons to move the window. however making it dance is a pain
zjblabs
NightMonkey: like the ogg stuff?
kbrosnan
NightMonkey: yes in about:config
Sensiva: the java stuff Firefox does not have much control over if you have the java plugin enabled
Sensiva
ok ... with all respect , I am not asking for help, I am just reporting an incident that may give any hints for FF developers
zjblabs
Sensiva: I'd say that that's more or less impossible to stop unless you wanted to get paranoid with noscript
Sensiva
I killed FF pid and its over, but I was shocked, like I am running FF and Linux, why would I see such stuff
kbrosnan
Sensiva
I didn't see such thing since IE days
zjblabs
however, I would also argue, on the other hand, that there are *no* legitimate reasons to move and manipulate browser windows
Sensiva
Ok , is there anyone interested in analysing the URL?
zjblabs
Sensiva: heh, I'll give it a whril (I'll change my hosts first :P)
Sensiva
or is there an appropriate place to submit it?
kbrosnan
posting it directly on this server will get you glined, so you might want to pastebin
so said the sops
zjblabs
Sensiva: I must say that watching a malicious script perform its evil is somewhat attractive
Sensiva
kbrosnan check your private please
zjblabs
Sensiva: pm please? :D
kbrosnan
you can go into the tools > options > content > javascript > advanced > and disable resizing or moving of the browser window
Sensiva
zjblabs at my side it wasn't at all, I am kinda losing my faith in FF, launching a java applet which connect to IRC server without my permission, is something I consider vulnerability
zjblabs check your private
kbrosnan and what about making outbound connection in java?
zjblabs
what in hell?
rjohnson19
Oh no :(
Sensiva
:\
kbrosnan
that would be in java land, they do their own stack
Sensiva
the curiosity killed him
hmm now I get it
Java to be blamed
~_~
kbrosnan thanks for your tip
bye all
kbrosnan
bye
NightMonkey
kbrosnan: Thanks.
Yes, I'm looking to disable OGG, so that I can have audacious handle it.
For some reason, MediaPlayerConnectivity isn't doing the trick.
kbrosnan
if it is in <video> it won't trigger plugins
NightMonkey
Hrm. I'm playing an audio OGG from an icecast server. It's a file that ends in .ogg (though I don't know what mimetype it is sending, I'll check).
I disabled MediaPlayerConnectivity, but the "ogg" type doesn't show up in Prefs->Applications.
Oh, mime type is "application/ogg"
Got an answer from irc.mozilla.org. Thanks.
kbrosnan
yeah ogg.enabled is what i meant with about:config
CodeWar
with firefox 3.6 I have jre/plugin/i386/ns7/libjavaplugin_oji.so being pointed to udner firefox/plugins/libjavaplugin_oji.so yet I m not able to get java to work
it works under firefox 3.5-7 though
kbrosnan
ubuntu? symlink the plugin to /usr/lib/mozilla/plugins where all the rest of the plugins live
CodeWar
opensolaris
i just symlinked jre/lib/amd64/* to firefox/plugins/. it doesnt work
kbrosnan
where did you get 3.6?
CodeWar
mozilla.com
kbrosnan
32-bit build
CodeWar
yes I see what you mean it only has i386 option
kbrosnan
64-bit plugins won't work
CodeWar
so where should I get the 32 bit plugin and whats the name of the files required
kbrosnan
java.com ?
your package manager if they provide 32-bit apps
CodeWar
kbrosnan, I dont understand you are asking me to download Java? I already have it and it has both 32 and 64 bit files. Question is what are these 32 bit files are they in the plugins directory?
do you know or are you guessing
kbrosnan
i was not aware that you had 32 bit java installed
is it the system default java?
CodeWar
ok its /usr/java/jre/plugin/i386/ns7/libjavaplugin_oji.so that you need to symlink to firefox/plugins
it works now
kbrosnan, solaris has only one build not two separate ones for 32 bit / 64bit kernel. the java installation for amd64 is a patch on top of the 32 bit one so you can use either -d32 or -d64 mode
I said it wrong it should eb libnpjp2.so -> /usr/java/jre/lib/i386/libnpjp2.so
chovy_
anyone have ssl cert issues? mainly addons.mozilla.org and google domains.
Peng
WFM. I probably don't have the answer, but please elaborate.
(Action) also points to irc.mozilla.org.
Are you using a mozilla.com binary? Distro build? Maybe your ISP is MITMing them?
`Orum
Is there an easy way to merge two password databases? I want to take all the passwords out of one (older) signons.sqlite, and import them into the newer db, without overwriting any entries in the newer db
chovy_
Peng: http://chovy.dyndns.org/err/ssl.png , http://chovy.dyndns.org/err/ssl2.png , http://chovy.dyndns.org/err/ssl3.png
this started happening a few days ago
i'm using macosx 10.5 -- don't know if i was hacked or what. but it's very annoying.
i tried re-installing 3.6
zpao
chovy_: is your system date set right?
chovy_
yeah
Fri Jan 22, 11:12pm
Peng
chovy_: Click to view more info; what is the certificate?
chovy_
here's an error i get when i try updating FF from "Help" menu: http://chovy.dyndns.org/err/malformed.png
Peng
...
zpao
do you get these problems with firefox 3.5? other browsers?
chovy_
nope, just firefox 3.5 (as of a day or two ago) and even with 3.6 (just updated).
http://chovy.dyndns.org/err/cert1.png
http://chovy.dyndns.org/err/cert2.png
those are 1 cert for a google domain.
Peng
...Google has a CA?
chovy_
no idea
it does seem odd.
Equifax?
Peng
I get the same cert for chatenabled.mail.google.com, but Firefox doesn't mind it.
Like I said before, I don't know much about this. :P
chovy_
firefox doesn't let me accept the cert (the button doesn't exist).
Peng
Prefs -> Advanced -> Encryption -> View Certificates -> Authorities, scroll down to Equifax. Are the two Google ones missing? Select one and click Edit, is it enabled?
(Or whatever the Fx 3.5 and 3.6 equivalent to this is...)
mahen23
huys
guys
firefox is freezing too much
each time that i close the utube tab, it freezes
am using 3.6
anyone else having this issue
chovy_
Peng: i deleted them to see if that would fix it (no diff). I trashed FF and re-installed, they aren't there anymore but i still get the same error.
Peng
Yes, deleting them sounds like a bad idea...
`Orum
mahen23: check that your flash is up to date
Peng
chovy_: There might be a better solution, but could you try, with Firefox closed, renaming cert8.db in your profile? Maybe something is wrong with it.
« prev 1 2 next »