logs archiveIRC Archive / Freenode / #exim / 2015 / September / 10 / 1
oasisfleeting
which is correct
henk
log message?
oasisfleeting
well...
i show on completed.
2015-09-09 16:45:12 1ZZnB2-0005Oe-0S <= info@pumpers.com U=pumpers P=local S=11514
2015-09-09 16:45:12 1ZZnB2-0005Oe-0S => studiobdallas@gmail.com R=send_to_mailgun T=maailgun_smtp H=smtp.mailgun.org [50.56.21.178] X=UNKNOWN:ECDHE-RSA-AES256-GCM-SHA384:256
2015-09-09 16:45:12 1ZZnB2-0005Oe-0S Completed
i'm currently trying to relay through mailgun
and the rejectlog
2015-09-09 16:05:53 H=rs224.mailgun.us [209.61.151.224] F=<bounce+69005e.f7ed5-pumpers=ns5.silicon-hosting.rocks@pumpers.com> temporarily rejected RCPT <pumpers@ns5.silicon-hosting.rocks>: failed to open /etc/exim/domains/pumpers.com/aliases for linear search: Permission denied (euid=93 egid=93)
ns5.silicon-hosting.rocks is the fqdn server hostname
exim can't read the alias file obviously
but there isn't anything in it anyway
what is it looking for? an alias to ns5.silicon-hosting.rocks@pumpers.com ?
henk
oasisfleeting: Id guess its looking for aliases, but the only way to know for sure is to look at the config &
Jckf
I'm having trouble reaching Google's servers over IPv6, causing mail delivery failure. Is it possible to disable delivery over IPv6 while still accepting incoming mail on it?
Log entries look like this http://pastie.org/pastes/10409814/text?key=mczojaaxtyuu66cx6qpx5q
notkoos
Jckf: you can set interface = option to your IPv4 address in SMTP transport
jgh_
or, if it's some specific recipient domains, a main-config option like "dns_ipv4_lookup = gmail.co" (to pick the example that plagued me)
rjek
(Action) ended up turning off IPv6 because of gmail :(
Jckf
Good to hear that I'm not the only one experiencing this at least
Where can I find the interface setting for the SMTP transport, and what exactly am I looking for?
I'm diving through my exim4.conf.template, but there's so much stuff =P
         

jgh_
Jckf
Okay, I think I understand this. Thank you :)
Will mail that previously failed go out after a restart?
jgh_
yup, and a reload would suffice
well, assuming said mail is still on the queue
Jckf
Less than 24 hours since I noticed the issue
jgh_
should be. "mailq" will tell you
Jckf
http://munin.flaten.it/exim-day.html
Looks like the queue is empty
mailq has no output
jgh_
either they went on their own, or your retry rules are so tight that you bounced 'em
Jckf
My rules would be that default Debian ones, so I don't know
jgh_
if you have a relevant exim mailid, grep the logs for it
Jckf
jgh_, http://pastie.org/pastes/10409860/text?key=xbai4f6etwttnfjhcuq
Nothing else
I'd think that completed means successfull delivery
jgh_
hmm. If that was one that was spotted as being queued, it was only by chance. It was there for just over a minute, so that is possible
it does
Jckf
The mail never reached the user though. Neither inbox nor spam.
rjek
(Action) is currently having a problem with hotmail; Microsoft's MXes accept the mail and even tell me it has been queued. It never appears in the inbox or spambox.
jgh_
the "=>> line says that [64.233.184.26] accepted it from us. It's now their responsibility
rjek
Microsoft are being a brick wall at diagnosing this
jgh_
"=>" even
apatheticsheep
hi all ... I am trying to setup exim4 to send all inbound mail for a specific domain to another host. i think that's the store_and_forward router ... I have a split config on debian and I am not too sure where to insert that config block. any help would be great.
henk
man exim4_hubbed_hosts
apatheticsheep
clear as mud
do i create an /etx/exim4/hubbed_hosts config file?
henk
well, yeah &
         

apatheticsheep
ya think i got it. now i have a strange paniclog thing ... doesn't seem to be stopping the server from running but I can't figure out where the error is coming from
says "exim4 configuration error ... option unknown ... " the "option" it is refering to is one of my domains minus the tld. odd since I can't find that string grepping through anything in /etc/exim4/*
anywhere else I can look?
and the only time it appears in my /var/lib/exim4/config.autogenerated is as the domain.tld in the "MAIN_RELAY_TO_DOMAINS" directive
henk
debconf-get-selections
« prev next »