logs archiveIRC Archive / Freenode / #exim / 2010 / April / 21 / 1
piem
hello. i'm using a standard debian exim4 config with several hosts in "dc_other_hostnames". how can i route message to info@virtualhost1 and info@virtualhost2 separately?
henk
what exactly do you want to seperate?
phx
piem, i'd suggest reading the docs on the routers and transports, also for each's generic parameters. you can match on the domain parts
petemc
theres plenty of info on running virtual domains with debians bastardised config, just be sure to avoid the rants of one of the debian maintainers against the word 'virtual'
piem
ok, i found a solution that fits me, it was quite easy based on this article: http://www.debian-administration.org/articles/140
i just had to create one file /etc/exim4/virtual/virtualhost1 with "info : localuser@localhost" in it
and add the file /etc/exim4/conf.d/router/350_exim4-config_vdom_aliases as written in the article
now it looks like everything works as expected, including falling back to local users when no configuration is found in /etc/exim4/virtual
DammitJim
I'm trying to install exim4 on debian lenny. AFter doing an apt-get install exim4 the system didn't take me through the configuration. How do I run that?
henk
DammitJim: dpkg-reconfigure exim4-config
petemc
dpkg-reconfigure exim4-config
DammitJim
thanks
weird that my system is not responding
this can be done on the terminal through ssh, right?
         

henk
yes.
DammitJim
do I have to stop exim?
henk
no.
DammitJim
this is so strange
henk
DammitJim: is it a physical or a virtual server? does the clock still run?
DammitJim
henk, it's a physical one
clock still runs ;)
I was going to install sendmail
but then I uninstalled it
hhmmmm
what log should I be looking at to see any errors?
petemc
syslog, messages
for general system errors
DammitJim
dpkg.log says: dpkg.log:2010-04-21 10:41:25 configure exim4 4.69-9 4.69-9
dpkg.log:2010-04-21 10:41:25 status unpacked exim4 4.69-9
dpkg.log:2010-04-21 10:41:25 status half-configured exim4 4.69-9
dpkg.log:2010-04-21 10:41:26 status installed exim4 4.69-9
sorry, should I have put that on pastebin?
petemc
are you having a problem with exim, or with your machine hanging?
DammitJim
this is the first thing that has "hung"
the exim4 process is running
petemc
so whats your question?
DammitJim
I can't get dpkg-reconfigure exim4-config to run
is that the best way to configure exim after apt-get install exim4 on debian lenny?
petemc
best is relative
if you're conversant with exim config syntax, the best way would be editing your own config file
try dpkg-reconfigure -fDialog exim4-config
failing that ensure exim4-config is installed
DammitJim
ah
Package `exim4.config' is not installed and no info is available.
petemc
thats now what i said
not
exim4-config exim4.config
DammitJim
ty
I think I'm confusing myself
Mail Server Configuration:
I will use my ISP's smtp relay to send email out
I'd like exim to receive my email
which option do I use?
mail sent by smarthost; received via smtp or fetchmail?
ok, now I'm trying to set up SMTP-AUTH client
I have added my server, username and password in passwd.client
what else do I need to do?
I'm getting 530 authentication required
ok, I can send email via my SMTP relay from my ISP
now I can't receive messages
what log should I look at for receiving messages?
do I have to specify my external IP address somewhere?
petemc
the logs are in /var/log/exim4/
receiving is controlled by dns
DammitJim
thanks
petemc
and unlikely to be an exim configuration problem
DammitJim
cool!
hhmmm.... maybe alpine needs to be configured
where does exim hold the emails?
         

petemc
wherever you told it to
DammitJim
petemc, or how can I check that I got an email
I'm thinking my email client might be misconfigured
petemc
/var/log/exim4/mainlog
DammitJim
interesting... no records in mainlog
petemc
nothing?
DammitJim
not from the test emails I've sent myself
petemc
oh, i already said thats likely a dns issue
whats the domain?
DammitJim
can you please expand on where to look?
mach.flnet.org
ok
trying
petemc
telnet mach.flnet.org 25
Trying 99.75.58.21...
telnet: Unable to connect to remote host: Connection refused
DammitJim
hhhmmmm
petemc
exim -bP local_interfaces
port 25 is commonly blocked by isps
DammitJim
local_interfaces = 127.0.0.1
petemc
that explains that, then
DammitJim
my ISP has it opened... I have another email server with sendmail running
oh man, it asked me about this local interfaces, but I thought it suggested to leave it
petemc
it probably did
DammitJim
I have to add my eth IP, right?
where do I change that?
johnfg
hi guys
Is anyone here using exim and openldap together?
I'm getting an error message from exim due to my authentication being done via kerberos and openldap.
I read some at exim.org, but can't really understand it.
DammitJim
petemc, I owe you a beer, man
you are very knowledgeable (if that's even a word)
thanks!
johnfg
I think specifically, I need to know how to make exim openldap aware.
« prev next »