logs archiveIRC Archive / Freenode / #exim / 2010 / April / 1 / 1
simonrvn
hi, was wondering if debian squeeze's daemon-heavy was built with DKIM, or do i have to build a daemon-custom?
well it doesn't seem to disable it...
efaistos
hi
i have a question ... i have a box with exim on it ... and have a lot of sendmail process from 2009 and dont know if I can kill them ... here the output of an pstree : http://gist.github.com/351748
phx
efaistos, uname -sr
efaistos
phx: it's a debian gnu/linux with with an old kernel 2.4.34
phx
netstat -ntlp iirc then. check which one of them is listening on 25/tcp
henk
debian linux? shouldn't even be possible to have sendmail AND exim on there... the packages conflict with each other.
phx
sendmail also can be the sendmail interface under /usr/[local/]bin/sendmail
or is it sbin?
yeah, sbin
efaistos
phx: yeah sbin/sendmail
henk
yes, but that's just a symlink to /usr/sbin/exim4
         

phx
henk, not for me!
it's mailwrapper here :)
henk
phx: we are talking about debian here ;)
phx
poor you, sorry :)
efaistos
lrwxrwxrwx 1 root root 19 Nov 26 2008 /usr/sbin/sendmail -> /usr/local/bin/exim
henk
phx: :-p
efaistos: that looks wrong for a debian.
efaistos
the thing I saw that it's listening on the port 25 ..
henk: dont ask I just arrived in this new company ;)
henk
efaistos: there are no symlinks to /usr/local/ in any debian package.
efaistos
they did a stow installation
henk
ouch...
have fun :)
efaistos
ahah
yeah and I should show you some perl scripts over here ... reallly nice ;)
anyway ... there is 137 sendmail processes ... and some are quite old ... 2009
and dunno if I can kill 'em
henk
i'd just SIGTERM them and see what happens and how the sendmail queue looks afterwards.
but i don't know what will happen :) i'd say the system is pretty inconsistent in any case, so you can't really do MUCH harm imho...
efaistos
that's the box for all emails over here ... dont want to mess too much wit'it ;)
hmmm whats that iscan/sendmail stuff ...
lrwxrwxrwx 1 root iscan 36 Nov 26 2008 /etc/iscan/sendmail -> /opt/trend/ISSMTP/IScan.SMTP/issmtpd
did anyone tried that ?
s/did/has/
pokui
hi all, is there anyone who can update the mirror list at http://www.exim.org/mirmon/ftp_mirrors.html ? many of those mirrors don't have a release beyond 4.69
henk
pokui: which one e.g.?
(i can't do anything about it, i'm just curious)
pokui
ftp.tin.org
ftp.mirrorservice.org
henk
hm at least tin.org is true... i wonder what sense that page has if it doesn't even check for the newest release.
phx: any idea about that?
phx
henk, i'll tell on next week when i'm at work again :)
bonez2046
I run 'telnet localhost 25' and get this > Trying 127.0.0.1... and then telnet: Unable to connect to remote host: Connection refused
how can I resolve this?
henk
bonez2046: is something listening on that port?
phx: thanks
bonez2046
henk: I have port forwarding and am on the server it points to..
how do I test this, and resolve it?
         

henk
bonez2046: netstat -alpen | grep :25
bonez2046
scott@fyrenice:/etc/exim4$ netstat -alpen | grep :25
(Not all processes could be identified, non-owned process info
or as root > scott@fyrenice:/etc/exim4$ sudo netstat -alpen | grep :25
[sudo] password for scott:
not responding correctly, is it?
henk: I know I sound like an idiot .. just got a mental block with all this
henk
bonez2046: yeah, nothing listening means exim (or an mta in general) is not running (properly)
bonez2046
ok. so I need to text exim thoroughly to get it dislodged?
I think I have it running now, henk
thanks
sort of running.
http://pastebin.com/nZzzkhF0 there's output from this > netstat -alpen | grep :25
henk
looks good
bonez2046
http://pastebin.com/tvEV5E3V
this is for an exim test..
it's not delivering like it shoudl though, is this possibly a transport or router section issue?
in my exim conf file?
henk
possible
bonez2046
I read this.. http://kubuntusk.pastebin.com/40JSLY5W and realize that my output from these tests does not include any 'deliver' lines..
any ideas on the delivery?
I get this in my paniclog > 2010-04-01 12:18:47 1NxOAy-0002EI-AE == scott@fyrenice.com R=spamcheck_router T=spamcheck defer (-24): Transport filter process failed (127): unable to execute command
henk? any ideas on this? something is not executing. is it exim4 or something else?
henk
bonez2046: check the transport mentioned...
« prev