logs archiveIRC Archive / Freenode / #exim / 2010 / March / 29 / 1
bet0x
Hello
anyone here
petemc_
you're best to ask your real question and wait
floyd__
hi
any way to set a custom smtp_accept_max_per_host for all IPs that are in the relay hosts list?
henk
floyd__: yes.
floyd__
could you give me an example? we keep the relay host list in mysql,
and when trying something like {${lookup{$sender_host_address}mysql{SELECT host FROM relay_hosts}{0}, I get:a single key was given for lookup type "mysql", which is not a single-key lookup type
and per exim manual, single key lookups do not support mysql
henk
floyd__: your syntax for lookup is wrong for use with mysql
floyd__
henk: so it should be only ${lookup mysql{SELECT host FROM relay_hosts} ?
like: {${lookup mysql{SELECT host FROM relay_hosts}{0} ...
henk
floyd__: i guess you need the sender_host_address in your query, but i'm not usre.
s/usre/sure/
floyd__
but, if i already have a relay_host list, can i make a lookup through that list instead of searching in a file or mysql?
         

henk
i guess so
floyd__
hmm
does that look ok?
smtp_accept_max_per_host = \
${lookup{$sender_host_address}lsearch{/usr/local/rsmail/smtp_max_per_ip}\
{$value}\
{${lookup mysql{SELECT host, 0 FROM relay_hosts where host='${quote_mysql:$sender_host_address}'}\
{\
${lookup{${mask:$sender_host_address/24}}lsearch*{/usr/local/rsmail/smtp_max_per_ip}}\
}}}}
henk
uhm, no...
at least not to me...
but that doesn't mean anything
floyd__
seems to work in my case
edgy
Hi, I don't recieve messages from my server though exim log shows 2010-03-29 17:22:02 1NwFqW-0008Fz-CR => me@gmail.com R=lookuphost T=remote_smtp H=gmail-smtp-in.l.google.com [209.85.221.28]
2010-03-29 17:22:02 1NwFqW-0008Fz-CR Completed
doesn't this means everything is Ok?
henk
define 'ok' please...
petemc_
it means the message was successfully passed on to gmail
edgy
henk, petemc_: but i didn't receive it at gmail and I even disabled my firewall what could be wrong and how to track such things
henk
edgy: perhaps it was bounced?
but apart from that: i had complaints about mails disappearing at google as well today. regarding mails up to three weeks old... perhaps google is having an issue in their mail infrastructure.
edgy
henk: if it's bounced how can I check it with exim?
petemc_
google doesnt usally make mails disappear
hotmail does tho
henk
petemc_: that explains the other disappeared mail 'g'
i had several to google, one for hotmail and one something else iirc... all did not make it to the recipient.
edgy: with exim? you can't. you will have a bounce mail at the senders mailbox.
or perhaps you don't, if the bounce was rejected 'g'
edgy
henk: actually I am sending from the shell like: logwatch --mailto me@gmail.com ;)
now I tried another mail and got 2010-03-29 17:41:55 1NwGA0-0000gv-RA ==me@myrealbox.com R=lookuphost T=remote_smtp defer (-18): Remote host smtp-in.myrealbox.com [69.169.179.17] closed connection in response to initial connection
something fishy? ;)
any hint on my issue?
petemc_
your ip address may not be reputable
edgy
petemc_: but in that case I thought gmail will respond with an error and I won't get completed in exim log, no?
beside my ip has an mx record and a reverse dns name
bonez2046
Is there any way to get rid of this message > * ALERT: exim paniclog /var/log/exim4/paniclog has non-zero size, mail system possibly broken < when I run /etc/init.d/exim4 restart ???
petemc_
echo "" > /var/log/exim4/paniclog , tho you might want to look in it first
waxman
A few days ago my exim had a segmentation fault but I couldn't find the reason for that. Maybe it was a wrong configuration setting because I was changing a few settings. Any suggestion what I could activate in case this happens again? (debian stable, exim 4.69-9)
bonez2046
how can I find out which config file exim is using on my system..
I have made changes to my config files but none seem to affect email flowing through exim4.. i.e., I think I have edited or updated the wrong files. how can I discover this?
petemc_
bonez2046: exim4 -bV , presumably you're using debian
         

bonez2046
petemc_: hmmm thanks..
CunningPike
bonez2046: Make sure that all exim processes stop completely - I find that 'restart' doesn't do it. I have to run 'stop' a couple of times and then 'start'
« prev