logs archiveIRC Archive / Freenode / #exim / 2010 / January / 13 / 1
Beber`
Hi,
is there to test deliver including $sender_address ?
-bt don't accept from
petemc
bhc
Beber`
I'd like to redirect some mails with a condition on the sender_address local_part
condition is ${if !eq {${lookup{$sender_address}wildlsearch{/etc/exim/blacklist}}}{} {true}{false} }
and /etc/exim/blacklist contain
^postmaster@.*:OK
it doesn't match
is that the way to use wildlsearch ?
CunningPike
Beber`: Try just 'postmaster@*' in your blacklist
Beber`
not working either
how can I test expansion like this ?
CunningPike
Well, what does the output from -bhc say?
When it reaches the test
Beber`: Here is ours:
${lookup{${address:$h_from:}}\ nwildlsearch {/etc/exim/local_sender_blacklist}
Beber`
condition are in routers
so no output with bhc
I want to test $sender_address (MAIL FROM), not DATA From header
CunningPike
Beber`: Let's back up a sec - what are you trying to accomplish?
Beber`
to redirect to a specific address all mail from postmaster@*
CunningPike> to you see the point ?
         

CunningPike
Beber`: What about /etc/aliases, then?
Beber`
router is defined as the first
maestrojed
I am trying to get my php mail scripts working on a LAMP test server I built. I just installed Exim. In my php.ini I have "sendmail_path = /usr/sbin/sendmail -i -t" /usr/sbin/sendmail is a symlink to exim4. What else do I need to do. I get no errors but my mail isn't going through either.
When I try to send mail via exim (not php) I get these errors http://pastebin.com/d30bf8f63
abou_7anash_009
hi using Lenny with Exim, how can I rewrite emails sent to root@localhost to come to me@mydomain.com did try out aliases file, this does rewrite the header but not the to email address stays the same.
phx
read the documentation's rewrite section
abou_7anash_009
Hi I am using exim to deliver me emails that are sent to local accounts, I use the aliases + newaliases + restart exim, it works for all accounts, but not for logcheck, if I do mail root I get an email if I do mail logcheck I dont get an email although it does leave my server
petemc
you dont need to run newaliases
henk
abou_7anash_009: check the logs...
petemc
exim -d -bt logcheck
abou_7anash_009
petemc: seems pretty fine, I am thinking about using rewrite rules instead of aliases but all the howtos i can find are for rewritting the source not destination.
petemc: can you give me a hint ?
petemc
read the spec
edgy
Hi, when I send a message a specific domain I get this in the log: ...R=lookuphost T=remote_smtp: retry time not reached for any host after a long failure period
any hint how to troubleshoot this? The message bounce with error: retry time not reached for any host after a long failure period
CunningPike
edgy: Not your problem, unless it's a network routing issue at your end
The advertised MX for the domain did not respond
edgy
CunningPike: the problem is that same email can send and receive from my gmail account
CunningPike: the domain I am sending is wdc.com
CunningPike
edgy: Perhaps they're blocking your MTA then
edgy: If you telnet to the MX on port 25, what do you get?
edgy
CunningPike: I get Trying 129.253.170.35...
CunningPike: which really seems to a problem from their side, right?
CunningPike: but how come they are able to send and receive from other emails?!
CunningPike
edgy: Our MTA can connect - can you ping that host?
edgy
CunningPike: can you please check that domain. It's Western Digital, which is strange
CunningPike: I cannot ping wdc.com
CunningPike
edgy: I suspect a block somewhere
edgy: Do a traceroute
edgy
CunningPike: it stops at 9 wsip-70-183-16-26.oc.oc.cox.net (70.183.16.26) 58.071 ms 58.308 ms 58.299 ms
         

CunningPike
edgy: Pastebin it
edgy
CunningPike: http://pastebin.ca/1749977
CunningPike: did you figure it out? It's a bit strange problem
CunningPike
edgy: Looks like some sort of routing problem. I'd talk to your ISP
edgy
CunningPike: I tried the traceroute from different servers, one in America and the other in Saudi and I am getting the same problem!
CunningPike
edgy: Hmm - here too. A pox on people who don't allow ICMP
edgy
CunningPike: so you cannot also ping. but can you telnet to 25?
CunningPike
edgy: OK - here's something - connecting from our MTA from a directly-assigned IP works - connecting from my home from a dynamic ISP address does not
So, I think they're applying some kind of reputation filtering
And your IP address is in a block with insufficient reputation
edgy
CunningPike: did you notice the strange name of their mx record?
CunningPike
What was strange about it?
edgy
CunningPike: it's called spam something
« prev next »