logs archiveIRC Archive / Freenode / #emacs / 2015 / August / 28 / 1
technomancy
aidalgol: I got my noveeeeeena
Lokathor
i hit C-z and emacs disappered. how do i get that emacs back?
or, is it just gone?
didi-ng
Lokathor: It is probably just minimized.
Lokathor: Are you running it on a terminal?
Lokathor
yes
didi-ng
Lokathor: If you shell has job control, try running `fg'.
s/you/your
Lokathor
it works!
didi-ng
:-)
aidalgol
technomancy: Yayy!!
technomancy: I still need to actually do something with mine.
technomancy
aidalgol: yeah I am still getting mine set up
kind of miffed that the iceweasel on arm is so old; it won't run keysnail. for some reason the security update that brought jessie to ff38 wasn't ported to arm
hard to blame that on debian though; it's really just mozilla's CADT causing the trouble
         

aidalgol
technomancy: Mozilla has CADT?
What have they been rewriting willy nilly?
technomancy
aidalgol: just changing compatibility for the plugin API
aidalgol
ah, that
technomancy
s/changing/breaking/
aidalgol
fair enough
technomancy
it's like ... why even package FF if you can't use keysnail?
what even is the point
aidalgol
I use firemacs, and am happy with it,fwiw.
technomancy
hm... I was disappointed by it when I tried it, but that was years ago
maybe I should give it another shot
aidalgol
As much as I want to hate Mozilla for some of their decisions over the years, I have to sympathise with the existential terror struck into them by Google (i.e. Chrome).
technomancy
yeah. what a mess.
usually "just use debian stable" insulates you from the madness, but then when a security update forces a new version on you it's like a chink in the armor
running different version numbers on different architectures is a new problem I've never had before =\
dalias
debian stable "insulates you from the madness" about the same way as not using a computer and only using land-line phones does
technomancy
dalias: I'm about ready to chuck my mobile phone off a cliff, so yeah ...
didi-ng
dalias: What is the problem with Debian Stable?
The last release is new, so I don't feel I am using old software.
dalias
that you're dealing with bugs and limitations from 5+ years ago :-p
didi-ng
s/new/recent
dalias: Nah, that's unfair.
"Debian 8.0 was initially released on April 26th, 2015."
quotemstr
https://code.google.com/p/android-developer-preview/issues/detail?id=3096&thanks=3096&ts=1440727594
rudybot
http://teensy.info/lNdi5e6OjR
quotemstr
LOL Android
How the fu*k do you break mv(1), Google?
technomancy
dalias: for the first time basically ever I've gone to using emacs from apt
dalias
:)
         

technomancy
24.4; works great
I can count on one hand the number of programs I use that are too old in apt
jtz
[21:58:13] <dalias> debian stable "insulates you from the madness" about the same way as not using a computer and only using land-line phones does
technomancy
and two of them are games for my kids
jtz
haha, good one
dalias
i remember using debian when even their unstable lacked emacs-23
and pre-emacs-23 had no unicode support
quotemstr
I constently get bug reports about old versions of Emacs
dalias
so the only option was to build from source
quotemstr
It's gotten to the point where I tell people to run trunk or don't bother
technomancy
dalias: yes, that's how it used to be
hasn't been like that in ages
well... maybe not ages, but a while
dalias
that's what i mean by "bugs and limitations"
for some types of software -- core system stuff -- you want it to just be stable (unchanging) and reliable
technomancy
sure; it used to be a problem back in the day. these days if you need new stuff, get it from guix and the rest of the system doesn't have to suffer.
dalias
but there's lots of software that's just not useful if it can't deal with present-day data and data formats
i agree debian is doing better in this area
didi-ng
dalias: I can't relate with this narrative. I use Debian Stable and everything is fine.
dalias
i don't use it anymore so i can't quantify how much better
but even as a non-debian-user i can see it to some extent
quotemstr
At least Debian stable supports dlclose :-P
dalias
lol is that graphitemaster's bot?
quotemstr
?
iMadper
Hi All. I'm trying to open a js file and got "Debugger entered--Lisp error: (error "Autoloading failed to define function javascript-mode")"
dalias
guess not
quotemstr
iMadper: In what version of Emacs?
iMadper
quotemstr: latest version of emacs 25. (built from git repo.)
quotemstr
iMadper: Repro from -Q
iMadper
quotemstr: Works well with -Q.
quotemstr
,-Q
fsbot
[0] If starting emacs with "emacs -q" fixes the problem, it's YOUR FAULT; check your .emacs. If "emacs -q" has problems but "emacs -Q" doesn't, blame your distro or local admin.
[1] it's also possible that you have triggered a bug rather than introduced one. but that is a low-frequency event.
iMadper
quotemstr: Yeah, I know it should be my fault. I just not sure why my configures will break it...
jlf
iMadper: ,,-q
fsbot
[0] If starting emacs with "emacs -q" fixes the problem, it's YOUR FAULT; check your .emacs. If "emacs -q" has problems but "emacs -Q" doesn't, blame your distro or local admin.
[1] it's also possible that you have triggered a bug rather than introduced one. but that is a low-frequency event.
quotemstr
,bisect
fsbot
[0] If "emacs --debug-init" doesn't help, comment out half of ~/.emacs and try to reproduce the issue. Recurse as necessary. See also ,,-q and ,,ielm.
[1] https://github.com/Malabarba/elisp-bug-hunter
jlf
iMadper: n.b. -q != -Q. if it works with -q then bisect
quotemstr
So you hear we're getting rid of GCPRO?
iMadper
jlf: Okay, thanks a lot. cc quotemstr
quotemstr
(Action) RFC2822s iMadper upside the head
MethylatorX
hi there
i tried to install monokai theme and created themes folder , and added in .emacs (load-theme 'monokai t) but it doesnt load
is this theme buggy ?
holomorph
it's probably not in the theme load path, or whatever it's called
MethylatorX
How to figure the load path ?
holomorph:
quotemstr
(message "%S" load-path)
holomorph
MethylatorX: see (info "(emacs) Custom Themes")
jlf
no
,a theme.*path
fsbot
2 matches. (custom-theme--load-path custom-theme-load-path)
jlf
(not load-path)
« prev 1 2 3 4 5 6 7 next »