logs archiveIRC Archive / Freenode / #centos / 2015 / August / 16 / 1
tharkun
I have 2 machines that will not start with any of the several kernel updates Centos 6 has had over the curse of its lifetime. I'm unable to debug the isue for lack of knowledge. What are my best search words to feed google and come with something relevant?
wolfy
tharkun: sharing the exact error that pops up would be a step forward
Ruffus
Hello. This is embarrassing, but, I'm using xfce on centos 7. I created a pptp vpn connection, but I see no option to connect to it. some help please?
sputnik0_m
Ruffus, you really shouldn't be using pptp anymore. it's compromised tech
Ruffus
it's what my company offers only
MS stuff :(
TrevorH
got a network icon in your top panel? click it and choose VPN Connections
and, yes, pptp is insecure
Ruffus
TrevorH, no network icon, and tried to add one, but none available
sputnik0_m
yikes. any possibility to offer a better solution?
TrevorH
I use MATE on my el7 laptop so no other help from here
         

Ruffus
sputnik0_m, probably not very soon
not_phrak
I'm thinking about swtiching out my server from Ubuntu LTS to centos. Can anyone point me to any sort of beginners guide to centos?
TrevorH
start with the wiki, install it in a VM and play
not_phrak
wow, I missed the wiki... I'm going to bury my face in it in shame now... gah
good lord I'm a moron
DiscordianUK
+
theskillwithin
how do I uninstall php and then reinstall a downgraded version of php?
Zathrus
just use yum downgrade
pj
what version of CentOS are you running and which version of PHP do you want?
Bahhumbug
yum downgrade fails in more situations than it works considering many repos don't keep old versions around.
pj
yes, plus it probably won't give the "downgrade" that you're expecting.
it will downgrade to a previous package, but not to a previous version of PHP.
Bahhumbug
theskillwithin: What does "rpm -q php" return?
theskillwithin
http://pastie.org/10353993 Bahhumbug
I think this 'atomic' problem is why I got stuck acctually
Bahhumbug
Oh, jesus...
Atomic should be avoided like an STD>
pj
@atomic
theskillwithin
yeah I have no idea what im doing haha
centbot
We strongly advise against the use of the Atomic Rocket Turtle repo, aka atomic or art; it replaces core packages and can, does and will cause stability issues with CentOS systems.
Bahhumbug
In fact, I'd rather HAVE an STD, it would be less painful.
pj
hahaha
theskillwithin
I used puphpet on vagrant to do the inituall install, so now I am stuck with my own meants to figure it out
Bahhumbug
remi :(
That's not atomic. That's another craptastic repo that should be avoided.
         

pj
also 6.7 is out now
@remi
Bahhumbug: we need a remi factoid
Bahhumbug
I would add that, pj, but I can't tolerate any more of his crying.
theskillwithin
maybe puphpet used atomic to do the install
pj
hahaha
theskillwithin
or maybe I did something stupid when I initially tried to downgrade
Bahhumbug
If someone else with options wants to add it to the bot, go ahead.
theskillwithin
which is more liekly
I probably looked up some way to downgrade php on the internet, and used atomic, now im fu*ked
centbot
Please keep language family-friendly while in this channel if you could be so kind. Thank you, we appreciate it.
Bahhumbug
pj, just so you're aware upon request from Evo and IUS folks I added this earlier today:
@ius
centbot
A good source for more modern mysql, php and python packages is the IUS repo. For more information please see http://iuscommunity.org and the #iuscommunity channel on this network.
pj
also, this ...
@panel
Bahhumbug
That alone will bring tears.
pj
@panels
centbot
Due to the gross changes that panels make to the underlying OS we are unable to support such boxes in this channel as they are effectively no longer running CentOS but rather a mixture of CentOS and the parts that they have replaced. You are encouraged to contact your hosting provider or panel vendor for further assistance.
Bahhumbug
I need to split.
theskillwithin
well, cant i just use a DIFFERENT package magnager? just ignore the atomic part?
pj
puphpet qualifies as this ^^^^
Bahhumbug
Good luck, theskillwithin
theskillwithin
gee thanks
pj
theskillwithin: what is the output of: yum repolist
let's see just which crappy repos you have on there now.
theskillwithin
wow its taking awhile to figure them all out
pj
heh
theskillwithin
http://pastie.org/10353998
so I am assuming I would start with something like, yum remove php
it seems like everything uses yum command =D
pj
ok, lots of really bad stuff there
I'll list what I see...
atomic, remi, rpmforge/repoforge, webtatic
all of that is crap, imo.
theskillwithin
I asked the host for specifics so I could set up my vm to match their server, but they were not very helpful
pj
ok, so now let's see what packages you have installed from those crap repos...
theskillwithin
ok
$ yum info Loaded plugins: presto, priorities, security Repository 'atomic' is missing name in configuration, using id Error: Cannot retrieve repository metadata (repomd.xml) for repository: atomic. Please verify its path and try again
pj
theskillwithin: one min
yum list installed | grep '@\(atomic\|remi\|repoforge\|rpmforge\|webtatic\)'
pastebin the output of this ^^^^^^
theskillwithin
http://pastebin.com/ZibcM3gf
oh man, that is an interesting way to use grep, the @\(blah\|blah.... Im going to have to look that up later =D
pj
ok, where are the numbers coming from at the beginning of the lines?
never seen that before in the output
theskillwithin
maybe yum list insatlled comes from a document, and mayne its just outputting the lines that data is on
pj
theskillwithin: except it isn't and it doesn't
theskillwithin
maybe grep just treated the output like a document and that was what happened to be the line numbre
so probably insignificant
i hope
pj
theskillwithin: it looks like you did "grep -n ..."
theskillwithin
ah probably setup like that on this machine
i think u can setup defaults for commands
Bahhumbug
Nothing in that list of repos is supported here. You would likely be better off backing up web content, nuking that instance and starting over, restoring web content as necessary.
repoforge == dead repo, no updates of substance for nearly 3 years
webtatic - garbage
theskillwithin
well I dont have to use anything in that repo? i mean it sounds like prefrablly I would uninstall and reinstall from a new repo at this point?
Bahhumbug
remi = garbage
pj
at any rate, all those packages in that list ...
you need to get rid of to clean up the machine.
theskillwithin
jesus on a stick
pj
replace them with packages from better repos if you really need them.
theskillwithin
blah its eaither that or do a new vagrant instance
« prev 1 2 3 4 5 next »