logs archiveIRC Archive / Freenode / #centos / 2015 / July / 27 / 1
jeremym
are there any differences with configuring openldap server on 6.6 than say just 6? just meaning for the howto guides
fenrus02
should be identical
ediT
anyone know if their is or will be a "catalyst" driver available for the newest amd gpu's that will also work with older cards
TrevorH
ediT: that would be a question for AMD really, they write the driver and decide that sort of thing
pj
ediT: I doubt there will be given AMDs history with that.
ediT
still no support that i know of now
elrepo doesn't have ? no
TrevorH
kmod-fglrx is in elrepo and elrepo-testing
ediT
fglrx, is available
hmmm
is that a new offering?
or did i some how not see that
TrevorH: >
TrevorH
it was lacking a maintainer in elrepo for while but now has one, it currently appears to only be in elrepo-testing for el7
         

ediT
umm, el7 =
TrevorH
enterprise linux 7
covers RHEL7 and all its clones
ediT
sigh,, :o
yes
TrevorH
for el6 it's just in elrepo
ediT
that makes me, happy. I want to install centOS 6.6
TrevorH
no idea what cards it supports but there are 4 versions there that show up with --showduplicates, 13.4, 14.9, 14.12 and 15.2
ediT
searching on elrepo for catalyst kmod, I have (2) amd hd 6970 cards
TrevorH
unfortunately it doesn't appear that there is a package like nvidia-detect for amd/ati cards, might be worth asking in #elrepo
nvidia-detect is a package that you install and run the executable and it tells you which kmod-nvidia version to install for your card
ediT
TrevorH: ok, thank you so much for your help
zauberfisch
is there a way to start services during the kickstart install?
I am installing kvm/virsh during inside %post in my kickstart file
and libvirt. after yum finishes, I want to call some virsh commands, but this fails because libvirt is not running yet
normaly I would do: systemctl enable libvirtd.service; systemctl restart libvirtd.service
but that won't work inside chroot
billings
I just manually create symlinks
zauberfisch
billings: was that a response to my question?
TrevorH
I'm not sure you'll get libvirtd running inside the chroot, you might have to kick it off after the first reboot to complete your tasks
zauberfisch
was thinking the same thing
I am ok with that
but not sure how
is there a best practice how to do that?
epequeno
hello, which package do I need to install to get nfs-secure-server?
TrevorH
I guess you either write a one-shot systemd unit file that removes itself once it's run or use the old fashioned /etc/rc.local
epequeno
so far nfs-utils and groupinstall 'file-server' have not worked
zauberfisch
TrevorH: since I have 0 experience with systemd, I probably go for rc.local
TrevorH
me neither but it doesn't look tricky
zauberfisch
TrevorH: I assume you mean creating a file like "/root/setup.sh", and append "/root/setup.sh && rm /root/setup.sh" to /etc/rc.local?
and something to remove the line afterwards
TrevorH: do you happen to have a link to a documentation or guide for the systemd approach that you could point me at?
         

TrevorH
have a look at /usr/lib/systemd/system/sshd-keygen.service
subdriven
zauberfisch: I've done the same thing & just have the kickstart pull a file in with wget or curl and have it in rc.local which installs some VMs. The end of the post-boot script (as I call it) removes references of itself from rc. and delets itself
this is obviously after the initial reboot of the box from installation
(Action) 2 cents
evil_steve
epequeno: on which release?
epequeno
evil_steve: 7.0.1406
TrevorH
@current
centbot
Current releases are 5.11, 6.6, and 7.1 (1503). You can determine your current release by running 'rpm -q centos-release'. Please understand that this channel is only able to support what is current.
zauberfisch
subdriven TrevorH: thank you both
I will look into it
I will look into the systemd approach first, sounds like a nice solution
but subdriven, would you mind sharing your script? for the case that I don't manage to get it running using systemd?
subdriven
I can't share the whole thing, but I can share the basics. Give me a minute to put it together
zauberfisch
subdriven: yes, of course. I am only interested in the parts relevant to executing the script
subdriven
zauberfisch: This should get you in the right direction. I'm sure there are easier/better/more efficient ways to do it though --> http://pastebin.com/uR2Bbh4U
That's just 2 lines in the %post of the kickstart and a few lines from the file it calls on reboot.
This has been tested on CentOS 6.5/6.6 but nothing else. It should work okay on 5 or 7
zauberfisch
subdriven: thanks
subdriven
yep, no prob. Give a shout if it doesn't work or you have questions. I'm usually around
zauberfisch
cool
I a actually seem to be getting somewhere with systemd though
I have created a systemd service file that starts my script
the only thing I haven't figured it is how to make systemd start my unit on boot
subdriven
yeah, I can't help ya there.
zauberfisch
oh, I think that was actually in the example TrevorH told me to look at. it might work if I make it PartOf=libvirt.service
pj
zauberfisch: systemctl enable blah.service
porjo
Anyone running 389 server on Centos7? I have it running but am missing the admin console (gui frontend). Everything I read indicates this should be available via EPEL as of Centos 7.1 but I can't see it there!?
zauberfisch
pj: hmmm
I made it a oneshot
without an [Install] section
so it didn't let me enable it
secondly, this stuff is created during the kickstart install, where the script is run inside chroot
so I can't use systemctl at that point
but I think I can solve this with PartOf=
my problem now is, that libvirt.service seems broken. or I am doing something wrong
because: systemctl status libvirt returns "Loaded: not-found (Reason: No such file or directory)\nActive: inactive (dead)"
which is confusing me
because virsh is working
pj
I'm not entirely sure that libvirt is a service
oh, libvirtd
zauberfisch
ah, yes. sorry
libvirtd
ah, fail
I actually used libvirt instead of libvirtd in my script
pj: thanks
haha
that "d" just cost me half an hour
pj
yw :-)
subdriven
(Action) had a 1 which was supposed to be a 2 cost him a day
not my finest moment
pj
you get those
evil_steve
porjo: can you please pastebin a list of your installed 389 packages?
porjo
evil_steve, I just got it working. Turns out 389-console package is still in EPEL 'testing'
zauberfisch
hmmm, though it is still not working with PartOf=
« prev 1 2 3 4 5 6 7 next »